Actualizar php 5.1 a php 5.2.6

Ver esta liga

http://bluhaloit.wordpress.com/2008/03/13/installing-php-52x-on-redhat-es5-centos-5-etc/

En resumen:

To install PHP 5.2.5 (Highest in repository at this time) you can make use of a RPM repository maintained by Remi. He has a repository for each distro, but to save you translating for the ES5 one I’ll give you the commands here. Run the following to get up and running:

wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-2.noarch.rpm
wget http://rpms.famillecollet.com/el5.i386/remi-release-5-4.el5.remi.noarch.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

You now have the Remi repository on your system, however it is disabled by default. Obviously you don’t want all of your packages been effected by this repository, however to enable it for a specific package, run the following:

yum –enablerepo=remi update php

You should now have the latest PHP5 installed:

# php -v

PHP 5.2.5 (cli) (built: Nov 10 2007 10:52:30)

Copyright (c) 1997-2007 The PHP Group

Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

3 comentarios en “Actualizar php 5.1 a php 5.2.6

  1. Anonymous dijo:

    Me sirvio para actualizar al PHP 5.2.8-1…..

    Actualize mi repo:
    ****************************
    #wget http://download.fedora.redhat.com/p

    #wget http://rpms.famillecollet.com/el5.i

    #rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm
    ****************************************************************

    Por defecto la repo esta descativada, para actualizar a PHP 5.2.8, ejecutar lo siguiente:

    *****************************************
    #yum –enablerepo=remi update php

    *************************************************
    Si les sale errores de confilcto con mysql, entonces actalizar mysql con la misma repo:

    ***************************************
    #yum –enablerepo=remi update mysql

    ****************************************

    Volver a actualizar php por si no actualizó:
    *****************************************
    #yum –enablerepo=remi update php

    *************************************************

    Luego reiniciar Apache:
    ******************************************
    #service httpd restart
    ***************************************

    Luego Instalar el paquete php-mssql:
    ***********************************

    #yum –enablerepo=remi install php-mssql

    **************************************

    Solucionado

  2. Me sirvio para actualizar al PHP 5.2.8-1…..Actualize mi repo:****************************#wget http://download.fedora.redhat.com/p…#wget http://rpms.famillecollet.com/el5.i…#rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm****************************************************************Por defecto la repo esta descativada, para actualizar a PHP 5.2.8, ejecutar lo siguiente:*****************************************#yum –enablerepo=remi update php*************************************************Si les sale errores de confilcto con mysql, entonces actalizar mysql con la misma repo:***************************************#yum –enablerepo=remi update mysql****************************************Volver a actualizar php por si no actualizó:*****************************************#yum –enablerepo=remi update php*************************************************Luego reiniciar Apache:******************************************#service httpd restart***************************************Luego Instalar el paquete php-mssql:***********************************#yum –enablerepo=remi install php-mssql**************************************Solucionado

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s